Announcement

Collapse
No announcement yet.

Trouble Opening Port Using Expert Rules + Public Zone Settings - ZA Pro 15.1.501

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble Opening Port Using Expert Rules + Public Zone Settings - ZA Pro 15.1.501

    Im trying to open port 6000 to run bittorrent. My Router is forwarding all traffic correctly however ZA is still blocking OUTBOUND connections going to a different Port.

    What ive done:
    1. Public Zone:= Allowed incoming + Outgoing UDP on port 6000
    2. Expert Rule:= Created New Protocol (UDP:6000); Source: Public+MyPC; Destination: Public+MyPC; Time: Any

    What is happening
    Only outgoing connections are being logged
    Connections are logged as ALLOWED for anything that is MYIPADDRESS:6000 to *.*.*.*:6000
    Connections are BLOCKED when the destination port is NOT 6000.

    What i want to happen:
    Allow all incoming connections to port 6000 from ANY IP and PORT (I think this is working)
    Allow all outgoing connections from port 6000 to ANY IP and PORT (Ideally only when an App is running)

  • #2
    Re: Trouble Opening Port Using Expert Rules + Public Zone Settings - ZA Pro 15.1.501

    Public zone probably does not need a rule.
    Expert Rule should be ingress from ANY to your computer on local port 6000 for udp.

    In the client, listed in za list of programs, make new expert rules:
    1. any out to any port for any protocol. (TCP, UDP ICMP, etc)
    2. any in to local port 6000 by udp.
    3. also make sure server for both trusted and internet are allowed.

    Open port 6000 in the router. (u have done).
    Make sure client is set always have port 6000 as it's dedicated port (not random).
    Best regards.
    oldsod

    Comment


    • #3
      Re: Trouble Opening Port Using Expert Rules + Public Zone Settings - ZA Pro 15.1.501

      Thanks for the tips, didn't know you could also set expert rules on an application hidden in those menus!

      Still not working though. Here's what i did:

      1. Removed old "global" expert rule
      2. Added new Expert rule#1 on Torrent App for INBOUND (Source:Any, Protocol: UDP:6000, Dest:MyPC, Time:Any)
      3. Added new Expert rule#2 on Torrent App for OUTBOUND (Source:MyPC, Protocol: Any, Dest:Any, Time:Any)

      Im still getting lots of BLOCKED entries for OUTBOUND connections MYPC:6000 to ANYTHING. Not sure what else to try. I cant see any other settings explicitly set to Block these connections. Im going to mess around with Rule#2 some more and see if i can get it working, any idea's would be appreciated.

      I still have "Global" ports opened on my Public Zone, can i remove these now that I've got them set on the Expert rule?

      Additional Info:
      The Torrent App is set to Allow Outbound/Inbound Trusted & Internet

      Comment


      • #4
        Re: Trouble Opening Port Using Expert Rules + Public Zone Settings - ZA Pro 15.1.501

        "2. Added new Expert rule#1 on Torrent App for INBOUND (Source:Any, Protocol: UDP:6000, Dest:MyPC, Time:Any)"
        Local port is 6000 (I mean the computer's port not remote server(s).


        "3. Added new Expert rule#2 on Torrent App for OUTBOUND (Source:MyPC, Protocol: Any, Dest:Any, Time:Any)"
        Change source to any.

        Yes remove Public zones entries.

        Add in expert rules (zones) "any in to your port 6000 by udp from any where".
        This is safe and secure, as the only application on this port woud be the client.
        Best regards.
        oldsod

        Comment

        Working...
        X